Project

General

Profile

Support #6618

Changes to the active setting group may not be tracked in some scenarios

Added by Ben Day 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
12/04/2023
Due date:
% Done:

0%

Estimated time:
ID:
Source:
TF Unique ID:
WG10 Proposal:
Estimated Completion:
Discuss in Upcoming Meeting:
No
To discuss in WG10:
No
Short Proposal:
Standard(s):
Needs More Information:
No
Assigned TF:
None

Description

SGCB behavior and service tracking was updated/clarified via issues #669 and #5284 to handle changes to the active setting group that are initiated outside of MMS. But, it is still unclear how to handle a scenario where the SelectActiveSG service request is successful, i.e. the server issues a Response+, but the activation is delayed until later or doesn't occur at all. Activation of a new group may take many cycles based on details of the application. So, a Response+ may only indicate that the request was successfully forwarded to the application.
In this scenario, service tracking would track success of the SelectActiveSG service request/response, but it would not track the activation outcome since the change was not initiated outside of MMS.

Proposal
Clarify SGCB service tracking for the SelectActiveSG service request/response covering all scenarios that could result in an update to ActSG and LactTm. Perhaps any change to ActSG and LactTm could be tracked as an InternalChange.


Proposal descriptions

Recommendation is that Issue reporter shall report this issue to the IEC61850 TISSUE DB (https://iec61850.tissue-db.com/ ).

#1

Updated by Vladan Cvejic 3 months ago

  • Discuss in Upcoming Meeting changed from No to Yes
#2

Updated by Vladan Cvejic 3 months ago

  • Status changed from New to Resolved
  • Assignee set to Ben Day
  • Discuss in Upcoming Meeting changed from Yes to No
  • Proposal descriptions updated (diff)
#3

Updated by Thierry Dufaure 2 months ago

Issues #669 and #5284 have clarified the SGCB behavior when changes of the active setting group are initiated outside of MMS.
However, the issues does not clarify the associated service tracking at all.
Service tracking are associated to the IEC 61850 object model and it is tracking IEC 61850 services on IEC 61850 objects.
Depending on the actual implementation of the setting group outside of MMS, i.e. inside the device, the SGCBTrk may be updated with internalChange or other services that are used to change the value active setting group.
BTW #667 is proposing the introduction of the activate setting group as a DataObject for Ed3.
Generally speaking, this is not solely a SGCB tracking issue, but the same discussion may apply to Control Service Tracking objects.

#4

Updated by Carlos Rodriguez del Castillo about 1 month ago

  • Status changed from Resolved to Closed

Tissue #1851 already concluded adding clarification in STS that the serviceType "SelectActiveSG", "SelectEditSG" or "ConfirmEditSG" shall be used as well when those activities were initiated not using IEC 61850 service but local means like through the HMI of the IED.

Also available in: Atom PDF