Project

General

Profile

Bug #449

GSE MaxTime and MinTime parameters are optional with no default value

Added by Herbert Falk almost 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Standard clarification required
Start date:
Due date:
% Done:

0%

Estimated time:
ID:
6
Source:
IOP_2013
TF Unique ID:
6 # IOP_2013
WG10 Proposal:

According to Cathedral City meeting (ref. to UFTF-CathedralMOM20160219) this issue is closed.

Estimated Completion:
Discuss in Upcoming Meeting:
No
To discuss in WG10:
No
Short Proposal:

Suggest that WG10 defines default behavior if these values are missing or declare them as mandatory for ED.2.

Standard(s):

IEC 61850-6

Needs More Information:

Description

An SCL file was attempted to be imported that had TMAX and TMIN missing. The expected behavior for this case is not specified. And the file import was rejected.
61850-6 defines TMAX and TMIN as optional in order to provide backward compatibility with ED.1 schema. However, in ED.2 the fact that these are needed to control the expected behavior creates a need to define the default behavior or to develop a ED.2 profile that can be applied in addition to the XSD for validation.
Submit the concept of profiling to WG10


Proposal descriptions

Solved in edition 2.1

#1

Updated by Herbert Falk almost 2 years ago

  • Priority changed from Normal to High
#2

Updated by Carlos Rodriguez del Castillo almost 2 years ago

  • Subject changed from An SCL file was attempted to be imported that had TMAX and TMIN missing. The expected behavior for this case is not specified. A to GSE MaxTime and MinTime parameters are optional with no default value
  • Status changed from New to Feedback
  • Standard(s) set to IEC 61850-6
  • Discuss in Upcoming Meeting set to No

Checking done.
Check if it is really solved because I do not see any solution in part 6 ed2 o 8-1

#3

Updated by Carlos Rodriguez del Castillo almost 2 years ago

  • Discuss in Upcoming Meeting changed from No to Yes
#4

Updated by Carlos Rodriguez del Castillo almost 2 years ago

  • Status changed from Feedback to Triage
#5

Updated by Thierry Dufaure over 1 year ago

IEC 61850-8-1 Ed2.1 as specified that minTime and maxTime are mandatory for a fully configured GSEControl.
(Text below table 163).
As well it is stated that:
"Configuration compliant with previous version of the standard may not contained the configured elements scl.tGSE.MinTime and scl.tGSE.MaxTime. It is a local issue of the publisher to use default values in that case. "

#6

Updated by Carlos Rodriguez del Castillo 11 months ago

  • Status changed from Triage to Closed
  • Discuss in Upcoming Meeting changed from Yes to No
  • Proposal descriptions updated (diff)
  • To discuss in WG10 set to No

Also available in: Atom PDF