Project

General

Profile

CIM Issues #5866

Add scheduledMeterReadingDate attribute (String) in the MarketEvaluationPoint class

Added by Herbert Falk about 2 months ago. Updated 26 days ago.

Status:
Closed
Priority:
Normal
Author/Contact Info:
Jan (ebIX 2019/6)
Base Release:
? Need to verify inclusion in WG14 package
Solution to be Applied To:
Solution Version:
Solution Applied By:
Completion Date:
CIM Keywords:
Breaking Change:
Breaking Change Description:
CIM Impacted Groups:
None
Requestor:
Standard(s):
Version:
Clause:
UsagePoint(originally MarketEvaluationPoint)
Sub-Clause:
Paragraph:
Table:
Originally Closed in Version:
Origination Date:
12/18/2019
Origination ID:
16_0086
Originally Assigned To:

Description

Add scheduledMeterReadingDate attribute (String) in the MarketEvaluationPoint class [0..1]

This will inform the Energy supplier when the (next) reading is done. Could be a date, or eg. with a format "MMDD". Example 0704 informing that regular readings are done yearly July 4th. Typically used for yearly read market evaluation points.


Proposed Solution

Was first suggested to be added to MarketEvaluationPoint. But was later agreed (spring 2020) to be added as a new attribute in UsagePoint:
nextReadingDate
Suggested definition: The indication of when the next meter reading is scheduled.

Still to check: Is a format "MMDD" possible to use with a DateTime attribute? Or should the attribute be of datatype "String"? Note also next issue.


Decision

Discussed in WG14 May 26th Mtg: Agreed on the addition of a new attribute in UsagePoint; nextReadingDate.

3/10/2022: Request a change to the attribute name of nextReadingSchedule; with a String datatype to allow the use of the next year or month such as "2022", "July" or "0704". What forms should be allowed - MMDD, YEAR, MONTH, MON, etc? Implementation would specify the rules for acceptable values.

4/21/2022: Added new Redmine issue; #5345

#1

Updated by Becky Iverson 26 days ago

  • Status changed from New to Closed
  • Proposed Solution updated (diff)
  • Clause changed from UsagePoint (originally MarketEvaluationPoint) to UsagePoint(originally MarketEvaluationPoint)
  • Decision updated (diff)

Duplicate of 5802

Also available in: Atom PDF